Je regroupe ici, les commandes que j'utilise lorsque je configure des switchs Cisco de la gamme Small Business.
Cisco# show system id
Cisco# show system unit 1
Cisco# show mac address-table
Cisco# show inventory
Cisco# show version
Cisco# show logging
Cisco# show arp
Cisco(config)# username cisco password myNEWpassword
Cisco(config)# username cisco privilege 15 password myNEWpassword
Cisco(config)# password aging 0
Cisco(config)# hostname Switch
Switch# copy running-config startup-config
Switch# write
Switch(config)# interface vlan1
Switch(config-if)# ip address 192.168.1.100 255.255.255.0
Switch(config-if)# no ip address dhcp
Switch(config)# ip name-server 192.168.1.110
Switch(config)# no ip domain lookup
Switch(config)# interface vlan1
Switch(config-if)# ip default-gateway 192.168.1.254
Switch# reload
Switch(config)# interface range ge1/0/4,ge1/0/30
Switch(config)# interface range ge1/0/4-18
Switch(config)# ip ssh server
Switch(config)# no ip http server
Switch(config)# no bonjour enable
Switch(config)# no pnp enable
Switch# show cpu utilization
Switch(config)# no macro auto
Switch(config)# delete startup-config
Switch(config)# no logging console
Switch# copy run tftp://tftp_server/YYYY-MM-DD
Switch# copy tftp://tftp_server/YYYY-MM-DD run
Switch# boot system tftp://tftp_server/firmware.bin
Switch# reload
Switch# copy tftp://tftp_server/firmware.bin flash://system/images/
Switch# show bootvar
Switch# boot system image-2
Switch# reload
Switch(config)# interface gi1/0/1
Switch(config-if)# no power inline
Switch(config)# interface gi1/0/1
Switch(config-if)# power inline auto
Switch# show power inline
Switch# show power inline gi1/0/1
Switch(config)# vlan database
Switch(config-vlan)# vlan 4
Switch(config)# interface vlan 4
Switch(config-if)# name VoIP
Switch(config)# interface GigabitEthernet 1/24
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan4
Switch(config)# interface te 1/0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan none
Switch(config-if)# switchport trunk allowed vlan add 4,100,101,150
Message : Your port has port security enable and has noticed that the MAC address on that port is different from what the port had originally learned.
Switch# set interface active gi2/0/4
Switch# show ports security gi2/0/4
Switch(config) # interface gi2/0/4
Switch(config-if)# no port security
Switch(config)# sflow receiver <index of the receiver> <sflow receiver ip> port 2055
Switch(config)# interface range GigabitEthernet1/0/1-48
Switch(config-if-range)# sflow flow-sampling 1024 1
Switch(config-if-range)# sflow counters-sampling 600 1
Switch(config)# interface TengigabitEthernet1/0/1
Switch(config-if)# no sflow counters-sampling
Switch(config-if)# no sflow flow-sampling
Switch(config)# monitor session 1 destination interface GigabitEthernet1/0/1
Switch(config)# monitor session 1 source interface GigabitEthernet1/0/2 both
Switch(config)# monitor session 1 source interface GigabitEthernet1/0/3 both
Switch# show clock
Switch# show sntp status
Switch(config)# clock source sntp
Switch(config)# sntp unicast client enable
Switch(config)# sntp server 0.pool.ntp.org
Switch# show spanning-tree
Switch(config)# spanning-tree priority 4096
Switch(config)# spanning-tree mode rstp
Remarque : Avant de stacker deux commutateurs SG, il faudra s'assurer que les modèles et le micrologiciel (firmware) soient identiques.
Switch01(config)# stack unit 1
Switch01(unit)# stack configuration links te1-2 unit-id 1
Switch01(unit)# do write
Switch01(unit)# do reload
Switch02(config)# stack unit 1
Switch02(unit)# stack configuration links te1-2 unit-id 2
Switch02(unit)# do write
Switch02(unit)# do reload
Stack# show stack configuration
Unit Id After Reboot Configuration
Unit Id Stack Links
-------- ------- ---------------
1 1 te1-2
2 2 te1-2
Stack# show stack
Topology is Chain
Units stack mode: Native
Unit Id MAC Address Role Network Uplink
Port Port
Type Type
------- ------------------- ---------- ------- ------
1 40:a6:e8:e6:9c:11 active gi te
2 40:a6:e8:e6:9c:12 standby gi te
Stack# show stack links details
Topology is Chain
UNIT ID Link Status Speed Neighbor Neighbor Neighbor
Unit ID Link MAC Address
------- -------- ---------- ----- -------- -------- -------------------
1 te1 Active 10G 2 te2 40:a6:e8:e6:9c:12
1 te2 Active 10G 2 te1 40:a6:e8:e6:9c:12
2 te1 Active 10G 1 te2 40:a6:e8:e6:9c:11
2 te2 Active 10G 1 te1 40:a6:e8:e6:9c:11
Switch01(config)# stack unit 1
Switch01(unit)# no stack configuration
Contact :